Results 1 to 4 of 4
  1. #1
    Prospect
    Join Date
    Jul 2020
    City
    Tulsa
    State
    Oklahoma
    Posts
    2

    after long ride bike won't start

    I have a 2017 StreetGlide I purchased brand new. I also purchased a 2yr extended service plan. So here we go I put 12" bars on myself no problems road for a year no problems, then one day we are out stop for gas and bike won't start. it has codes for right hand controls. take it to the dealership they replace right hand controls at my cost because I changed the bars myself they refuse to warranty any parts on the handle bars, everything is good for about 4 months issues comeback take it back to the dealership bad pins on the wiring the replace wiring harness and everything is good, for about 8 months. So as of 2 weeks ago we were out on a short ride 30 minutes ate dinner had a few drinks come out won't start right hand controls code. ( Quick note every time it has done this it calls out 3 problems ECM-Y,BCM-Y, and RAD-Y.) So we get picked up get a truck and a trailer come back I decide to check and it starts right up no issues. I clear off the codes and take it home, following weekend exact something soon as I get back with a trailer it starts. So scheduled a service take it in they sy this time its the left hand controls, replaced out of pocket another 360.00 for a grand total of 1010.00 for these issues. And guess what road 100 miles yesterday came out to go to lunch and wouldn't start, same codes calling out right hand control issues, called the dealership they picked it up and now I am waiting for there response. I told them don't fix anything until I talk to Harley corporate (waste of timothy were no help, "bike is out of factory warranty,out of extended service plan and since I replaced the bars all things are not covered. I know its a long post but has anyone had these same issues with the 2017 model?

  2. #2
    Did you use the wire extensions? I had the issue and it actually turned out to be a loose connection where you plug the bar wires into under the radio area, it just hadn't fully seated and the vibration caused it to wiggle around throwing codes.
    2014 Daytona Blue Pearl
    Painted Vented Lowers, Chopped Tour-Pak
    V&H Dresser Duals w/Twin Slash Round, 12" Monkey Bars, SE Heavy Breather, V&H FP3
    Sony XAV-AX5000, Soundstream PN4.1000D amp, Biketronics 7.1 BT7P14 Fairing Speakers, Bad Dad Competition Series Speaker Lids with LED Lights & Biketronics 5x7 Speakers, Bad Dad Summit rear fender, Top Shop extended bags.

  3. #3
    Prospect
    Join Date
    Jul 2020
    City
    Tulsa
    State
    Oklahoma
    Posts
    2
    Right now the dealership has it, until they tell me I'm going to be out anymore money, then I will pick it up and start my own diagnosis

  4. #4
    Founding Member TomA's Avatar
    Join Date
    Apr 2014
    City
    Battle Mountain
    State
    Nevada
    Posts
    1,811
    Have seen this several times where the plug isn't seated all the way. Check there first and make sure they are all seated.


    2014 Mysterious Red Sunglo
    Stage 1 D&D Boss Fat Cat 2-1 exhaust FP3 tuner
    JW Speaker E2, Custom Dynamic running and tails, 8 plasma rods
    Soundz Customz level 5 Carbon Iron series, 5x7 lids
    Color matched inner fairing and King tour pack with lowers
    Fork fangs, Fairing deflectors, REDA bag bolts

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •