Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11
    Founding Member buckshot85's Avatar
    Join Date
    Aug 2013
    City
    Cowtown
    State
    Wisconsin
    Posts
    845
    I can tell you that mine was the top dog bone mount. Got caught behind a dump truck in the rain in Utah on a sloppy road. Had that squeak for the rest of the trip.
    Got home and started looking. Had it on bumps and at idle. Took a long screwdriver by the tip and started pushing the handle against everything while it idled. For me it was that mount.
    Took it off washed it out with brake cleaner while rotating the ball joint. Installed and all is quiet. You really don't want lube on it. It will just attract more dust or debris.


    '15 FLHTK
    Fuel Moto Tune, 114/128
    D&D Boss FatCat, 2-1
    Power Vision Tuner
    Ness Slot Track Breather
    Fuel Moto 107 10.5 Pistons
    Fuel Moto Level B Heads
    Wood 777 Cams
    Torrington Cam Bearings
    Knight Prowler Lifters
    Fuel Moto Adj. Pushrods
    AIM Clutch Module
    HD Premium Front Suspension
    Chrome Fork Lowers.
    Legend Revo-A 13" HD Rear Shocks
    WO 577 12.5" Bars
    Arc Audio 600.4 Moto Amp
    Focal EC165K fairing speakers
    Focal ISC165 tour pak speakers
    Mustang Solo & Touring Seat

  2. #12
    Founding Member azglocker's Avatar
    Join Date
    Dec 2015
    City
    Gilbert
    State
    Arizona
    Posts
    320
    Funny mine cured itself. I never investigated it but it has gone away. Now if I can get my gas cap to stop rattling life would be perfect!

    Sent from my SM-G950U using Tapatalk
    2018 Street Glide, Wicked Red.
    SE stage 1
    Mustang seat
    LEDs!

    daily driver. living in AZ, it's always riding season!

  3. #13
    Member El Chapo's Avatar
    Join Date
    Aug 2015
    City
    Safford
    State
    Arizona
    Posts
    64
    Thought I had it figured out as I tried everything suggested, finally installed a new engine mount which was a PIA and went away for a month. Now it's back. Haven't tried the upper dog bone as someone suggested but that's the last thing left. If that don't do it, I'll wash her up and my excuse to purchase an 18. YES that's how bad it is. almost embarrassing. It's at idle, seems to be worse when coming off a rough paved road. And another clue is seems to be worse when 2 up and mama isn't a big girl.
    2014 Street Glide Charcoal Pearl, Vance & Hines power duals, Vance & Hines OS 450 Raiders slip-ons, Vance & Hines VO2 air intake, Vance & Hines FP-3 programmer
    Yaffe 12" bars, Rockford Fosgate amp, Polk Audio speakers, LRS shield, Michelin Commander II, 4 point docking with HD backrest. HD luggage rack. Performance Machine contrast cut trim. Removable color match tour pak.

  4. #14
    Member fcerrone's Avatar
    Join Date
    Apr 2015
    City
    Morgan Hill
    State
    California
    Posts
    53
    Quote Originally Posted by El Chapo View Post
    Thought I had it figured out as I tried everything suggested, finally installed a new engine mount which was a PIA and went away for a month. Now it's back. Haven't tried the upper dog bone as someone suggested but that's the last thing left. If that don't do it, I'll wash her up and my excuse to purchase an 18. YES that's how bad it is. almost embarrassing. It's at idle, seems to be worse when coming off a rough paved road. And another clue is seems to be worse when 2 up and mama isn't a big girl.
    Check the exhaust mount bracket mounting bolt(Allen) at tranny .cross over pipe! Mine loosened up drove me crazy!


    Sent from my iPhone using Tapatalk
    Frank
    2015 FLHXSE CVO Street Glide SE 117 kit
    "Carbon Crystal" with Ghost Flames
    Legends front Axeo
    13" rear revo A
    Paul Yaffe 8" bagger monkey bars
    Baker Drivetrain DD7 speed transmission
    Baker Compensator w/armoured attitude chain adjuster
    Baker Bully Primary cover with highlights
    SE 117 Kit
    SE 259e cams
    Fullsac DX header pipe
    2.25" baffles and screens,TTS Mastertune
    Dyno work by Bob @ RC Cycles in Hayward Ca.
    Dyno results New 117 build Nov 2017 126HP/129.15 TQ

  5. #15
    Prospect
    Join Date
    Oct 2015
    City
    Brewster
    State
    Massachusetts
    Posts
    9
    Glad I found this thread! Squeaking started in June , damn near disassembled the bike trying to find it. It was the dog bone. Cleaned it slike buckshot said - all good.
    Speaking of the gas cap rattle , I superglued a small rubber washer to each of the rubber bumpers the cap sit on - gone
    Now I can hear all the other tapping , rattles & whirring w/o distraction. Love that boom box!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •