Results 1 to 8 of 8
  1. #1
    Prospect
    Join Date
    Feb 2017
    City
    Cedar springs
    State
    Alabama
    Posts
    6

    Brake lights not working properly

    I went out to the garage today to start up my street glide and wishing the snow would go away when I noticed my brake lights not working as they should. When I hit the brakes the stock brake lights donít come on only the custom dynamics plasma rods and tribar do? I do have the custom dynamics LED bulbs in the stock brake lights also. The blinkers and run lights do work on everything. I did unplug the Dynamics stuff and put a stock bulb in and it does the same thing. I attached a picture of my setup. The center of the custom dynamics brake lights are supposed to light up when hitting the brakes but they donít?

    Everything worked last time I tried them. The only thing I have done to my bike sense then is swap out the 4.3 radio for the 6.5 gps head unit and did a software update to it.

    If anybody has an idea whatís wrong please let me know.


  2. #2
    Prospect
    Join Date
    Feb 2017
    City
    Cedar springs
    State
    Alabama
    Posts
    6
    Well I tried testing a few things and so far I havenít found a solution. The custom dynamics tribar and plasma rods light up when hitting the brakes but not the stock break lights so I figured there had to be something wrong with those. I ended up buying another set off of eBay and those donít work either? Anybody have any ideas to what I should be checking?

  3. #3
    Senior Member
    Join Date
    May 2016
    City
    El Paso
    State
    Texas
    Posts
    142
    Quote Originally Posted by littlenoz View Post
    Well I tried testing a few things and so far I havenít found a solution. The custom dynamics tribar and plasma rods light up when hitting the brakes but not the stock break lights so I figured there had to be something wrong with those. I ended up buying another set off of eBay and those donít work either? Anybody have any ideas to what I should be checking?
    Do the outside ring of small LEDs light up to full intensity when brakes are applied? When you activate a turn signal, does the inside led plate blink on the stock light bar?


    Sent from my iPad using Tapatalk
    2015 Street Glide Special (Vivid Black): Stage 1 - FP3, DK Custom Hi Flow 606 air cleaner w/ premium discrete external breather, Freedom Performance Eagle 4" slip-ons.
    Long Ride 7" windshield | custom screen on fairing vent | Eagle lights black face LED headlight | CD LED turn signals frot and back | Alarm siren mod | 3M protective film on fairing, lower tank and saddlebags | carpeted saddlebags | Avon edge cut grips | HD Edge cut saddlebag latch covers

  4. #4
    Senior Member
    Join Date
    May 2016
    City
    El Paso
    State
    Texas
    Posts
    142
    Have you called custom dynamics and given them the model of brake light leds that you are using on your 2014+ St. Glide? I was interested in those but I was told those type of lights need and extra module to make them work on newer street glides. The signal has to be split instead of being on one wire.


    Sent from my iPad using Tapatalk
    2015 Street Glide Special (Vivid Black): Stage 1 - FP3, DK Custom Hi Flow 606 air cleaner w/ premium discrete external breather, Freedom Performance Eagle 4" slip-ons.
    Long Ride 7" windshield | custom screen on fairing vent | Eagle lights black face LED headlight | CD LED turn signals frot and back | Alarm siren mod | 3M protective film on fairing, lower tank and saddlebags | carpeted saddlebags | Avon edge cut grips | HD Edge cut saddlebag latch covers

  5. #5
    Founding Member
    Join Date
    Feb 2015
    City
    Kansas City
    State
    Kansas
    Posts
    1,027
    Is your battery fully charged? I have all Custom Dynamics LED lights, tri-bar and plasma rods on my 2015 SGS and whenever the battery gets low from playing the stereo with the engine off, my rear brake lights don't work and everything else does. If your bike is a 2014, a new battery might be in order if it won't hold a charge. You can test it by riding it (and having someone follow you in a car), to see if the charging system takes the load and apply the brakes. If the brake lights work, then that will confirm that your battery needs to be replaced.
    Last edited by NGOT8R; 03-08-2018 at 09:58 PM.


    2015 Vivid Black SGS w/107 motor: V&H Pro Pipe, Thundermax tuner, SE Ventilator Elite AC with K&N filter, Andrews 30T pulley mod, AIM variable pressure clutch, Evolution Industries billet clutch basket, Twin Power compensator eliminator sprocket, HD highway pegs, HD passenger floorboards, RB Racing modified stock swingarm (2" over adjustable), HD 7" Wind Splitter windshield, HD black windshield trim, JM Corp 250W 2 channel amp and Focal 165 KRC speakers in fairing

  6. #6
    Prospect
    Join Date
    Feb 2017
    City
    Cedar springs
    State
    Alabama
    Posts
    6
    The small LEDs are not effected when pressing the brake. The blinkers do work. I did put the stock bulbs in and they do the same thing no brake lights but running and blinker lights do work. I did disconnect all the custom dynamics stuff and it made no difference so I donít think they are the problem or the battery. I have not checked the brake switch yet but I would assume if the plasma rods work when pressing the brakes the switch is fine.

  7. #7
    Founding Member BluesBelly's Avatar
    Join Date
    Oct 2014
    City
    Alexandria
    State
    Minnesota
    Posts
    885
    If the plasma rods light up when braking you then know that the problem is somewhere between the under seat brake light connect plug for the rods and the bulb socket at the rear of the bike. Use a simple electrical test light to locate where there is current and then work your way toward the rear of the bike till the light does not light up when brakes are applied and you have located the area of your problem. It can happen that a pin in an electrical plug is not seated correctly or is loose and has slipped when plugging and unplugging. One more thing to check is the condition of the wiring. Mice like to chew wires. When installing LED plugs into regular 1157 or 1156 sockets it's important to clean away all the dielectric grease from the oem stock bulb sockets before twisting in the new led lights.

    Good Luck,
    Blues
    2014 FLHX Brilliant Silver Pearl
    Fuel Moto air intake
    2014 CVO mufflers
    13" Ultra air shocks
    Custom Dynamics LED's
    10" dark tint Wind Vest
    Fairing mount air deflectors
    Fork Fangs
    Saddlebag guards
    HD Detachable sissy bar, back rest,
    and detachable Air Wing rack
    6.5 Boom stage I speakers
    Midframe air deflector.
    Soft Brake 2" Extended brake pedal and 1.5" shift arm
    HD 1" extended swept floorboard pans with 1" outward extensions
    Grips, 4" mini passenger boards, & much Misc

  8. #8
    Prospect
    Join Date
    Feb 2017
    City
    Cedar springs
    State
    Alabama
    Posts
    6
    The CD tribar light works as a brake light also and that lights up when hitting the brakes. So I know at least all should be good to that point. Thatís why I thought for sure the problem would be in the wiring on the stock tail lights and thatís why I bought another one but when I plugged it in the brake lights still donít work. I even tried the stock tribar light thinking there was something wrong with the connection in the CD tribar.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •