Results 1 to 3 of 3
  1. #1
    Prospect
    Join Date
    Nov 2016
    City
    East Brunswick
    State
    New Jersey
    Posts
    4

    Help needed with Rockford HD14-TKIT on my 16 Streetglide

    I need some Audiophile Help please. I just installed the Rockford Fosgate HD14-TKIT. Front Speakers and Amp kit. Here's my Problem. When the bike gets up to 4th gear or so the right speaker consistently cuts in and out. I have the Amp set on the factory specs from rockford and all the connections are solid because when the bike is Idle there is no issue. I'm playing music through a dedicated IPOD that is plugged into the bike. Any Ideas ?
    2016 SGS

    Avon Grips
    FP3
    Vance and Hines Eliminator 800's
    Custopm Dynamics L.E.D. Lights Blinker
    Hog Workz L.E.D. Headlight
    JNR Air RIde
    Front Fork Deflectors
    Arlen Ness Air Cleaner
    <div style=text-align: center;>

  • #2
    Prospect
    Join Date
    Mar 2019
    City
    Hyattsville
    State
    Maryland
    Posts
    14
    I am going to install this soon. Did you solve the problem? Any heads up you can offer would be appreciated. Any special tool you wish you had during installation? Thanks.


    Sent from my iPad using Tapatalk

  • #3
    Prospect
    Join Date
    Nov 2016
    City
    East Brunswick
    State
    New Jersey
    Posts
    4
    They replaced my entire system. I posted the tool you need in your other Rockford thread.
    10mm Flexible Pivoting Head Ratchet Combination Spanner wrench
    2016 SGS

    Avon Grips
    FP3
    Vance and Hines Eliminator 800's
    Custopm Dynamics L.E.D. Lights Blinker
    Hog Workz L.E.D. Headlight
    JNR Air RIde
    Front Fork Deflectors
    Arlen Ness Air Cleaner
    <div style=text-align: center;>

  • Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •